
AgilityRocks! software for agility trial scoring - setup  

Please note, some of the screens have changed slightly, but the basic instructions are the same. This 

document does not include installation instructions, see the download page instead.  

After installation, when the program runs for the first time:  

  
If you have your license (emailed to you) click Install License and follow the instructions in the email, 

otherwise click Continue Evaluation.  The license may be installed at a later time from the File menu in 

the program. Evaluation mode allows you to fully run the software except that all printing and reports 

have “demo version” splashed across them.  

  
The Options dialog will open, letting you make your initial settings:  

• Data folder: is the location for your database. It will be created when you complete and save 

your settings. Click the ellipsis (...) button to pick it or create a new one.  

• Scribe sheets per Page: 1 or 4. The 1 setting will print on a ¼ size page. Cut your paper first, then 

the scribe sheets will print in running order, no sorting required.  

• Email from: Your email address.  

• Mail server name: Use the setting for your outgoing mail server from your regular email.  

• Mail server port: Also from your regular email, the normal is 25.  

• Mail login name: Also from your regular email. The name you use to login to your email account. 

  Mail login password: The password for your email account.  

All fields must be filled in. The ‘Mail’ settings are used to send email confirmations and bulk emails from 

the program, and they must be set to an existing email account for you to send emails from the 

program.  

Click the Save button to continue.  



  
Click Yes to create your database.  

When the database has been created, the AgilityRocks! main screen will open and the next dialog will 

appear.  

  
Click Yes to create your first trial.   



  
The Trial Settings form will open so you can start to set up your trial.  

1. Trial name: This will appear on all your reports. You can change it at any time.  

2. Association: This is AAC, CKC or Regionals depending on your license.  

3. Start date: The first day of your trial.  

4. End date: The last day of your trial. Use the same date for a one-day trial.  

5. Entries: The closing date for your entries.  

6. Number of rings: The number of rings used for this trial.  

7. Build time: In minutes, this is your default which can be overridden for each class if desired. 8. 

Walk time: In minutes, this is your default which can be overridden for each class if desired.  

9. Starting times: Use a 24-hour format e.g. 18:00 for 6pm or 08:00 for 8am.  

10. Report folder: This is the default folder for your reports for this trial. Click the “...” button to pick 

one. It will be created if it doesn’t exist.  

  



11. Judges: Right-click in the blank area and select “Add judge” to open the main judges list: 

 

  
Click ‘Add’ to add names that are not on the list. Hold the Ctl key while you click to select 

multiple names. Click ‘Select’ to add the selected names to your trial settings.  

12. Fees: Right click anywhere in the fees box to add fees. A selection menu will pop up with a 

variety of fee types to choose from. You must have at least one runs fee.  

   
Package priced fees can be handled by adding a “discount amount” fee which will be subtracted 

from the total e.g. all runs $10.00, 4 run discount $5.00 would give you a package price of 

$35.00 for 4 runs. The program does not automatically calculate this, you can select it when 

adding your entries. Discount percent fees will calculate a percentage of all run fees less any 

discount amount. You select this when adding your entries. 

 
Fees based on total number of runs for a handler can be calculated automatically by the 

program if you set Min/Max runs. This is calculated over all runs for handlers with multiple dogs.  

  

Click Save to save your settings and close the form.  



  

The current trial name is displayed on the program’s title bar.  

The program version, license info and current printer are displayed on the status bar.  

Adding classes to the trial:   

  
Select View→Class Settings from the main menu. It is easiest to enter the classes in running order.   

  
Right-click in the blank Event Schedule and select ‘Add a class’. This will activate the form for you to start 

entering the class info. Fields with a yellow background are required.  



  
1. Performance level: Select Starters, Advanced, Masters or All from the drop-down.  

2. Class type: Select from the drop-down.  

3. Name: This will auto-fill when you select the class type. This is the name that will be 

displayed/printed for this class. Add to it or change it to suit your needs.  

4. Day: The day of the trial that this class will run.  

5. Ring: The ring this class will run in.  

6. Event#: This will auto-increment. You don’t need to reset it. This is used for the display/print 

sequence and must be unique to each class.  

7. Code: The AAC or CKC code for the class. It will auto-fill when the Performance level and Class 

type are selected. You can change it if needed.  

8. Judge: The judge(s) you selected in Trial Settings will appear in the drop-down for you to pick 

from.  

9. Unofficial class: Check this box if the class is not an official AAC class, e.g. a jackpot class.  

10. Fee: This is the fee for an unofficial class ONLY. Do not enter a fee here for the official classes.  

11. Height order: Your choices are small to tall and tall to small. Can also be set in the Running Order 

screen.  

12. Combined: Your choices are none, Specials+Vets and All. Can also be set in the Running Order 

screen.  

13. Regulars first: Uncheck this box to have Specials/Vets run first. Can also be set in the Running 

Order screen.  

14. Building: Time in minutes for building. This comes from your trial settings and can be changed 

here for this class. Set it to zero for the first class of each day for the schedule to calculate 

correctly.  

15. Walkthrough: Time in minutes for the walkthrough. This comes from your trial settings and can 

be changed here for this class. Set it to zero for the first class of each day for the schedule to 

calculate correctly.  

16. Each run: This is the estimated time for each run. It is used to calculate the schedule.  

17. Yards and SCTs will be set on trial day and can be set here or from the Scoring screen.  

  



  
Click Save on the toolbar or press Ctl-S. The class will be added to the Event Schedule list. Right click the 

list to add another class or press Ctl-N. Click the black ‘x’ on the upper right right to close the screen 

when finished. You will be prompted to save your changes if you try to exit without saving.  

Adding owners and dogs:  

  
Select View→Owner Settings from the main menu.  

    

1. The owner’s first name.  

2. The owner’s last name.  

3. Phone number – this is not formatted for you, enter the way you prefer.  

4. Address.  

5. City.  

6. Province will set to upper case for you, 2 letters only.  

7. Postal code will set to upper case for you.  

8. Email address.  

Click a blank area in the ‘Select’ list to add another owner, or right-click there for a pop-up menu.  

  



Entering dog information:  

  
1. List of dogs for this owner. Click here to add more.  

2. The dog’s call name.  

3. The dog’s breed.  

4. The dog’s birthdate. Click the down arrow to open a selection box (see below). This can be left 

blank if not known.  

5. The dog’s height in inches (optional).  

6. The AAC dog ID number. Can be left blank if not known when you enter the dog.  

7. The height division for this dog. This field is mandatory.  

8. The registered name with AAC, can be left blank.  

  

Birthdate selection:  

Click the month/year to go to the month view (below).  

  

  

  

  

  

Click the year to go to the year view (below).  

  

  

Use the left/right arrows to move a page at a time to 

make your selection.   

  

  

  



Entering dogs in the trial:  

  

Select View→Entries from the main menu.  

  

1. List of all owners/dogs in your database.  

2. Owner/dog information for the selected dog.  

3. List of classes the dog is entered in.  

4. List of bill items, payments and credits showing the current balance owing.  

  

  
To enter a dog, click on the name in the ‘Dogs’ list and click ‘Yes’. The owner/dog information area will 

be filled and the ‘Dogs’ list will change to the ‘Classes’ list for you to pick classes.  



  
Click on a class to add it to the dog’s entered classes list. This will also update the Bill Items area. Add all 

the desired classes for this dog.  

  
Click the ‘Other Fees’ tab to select any extra fees or discounts for this entry. Click the item to add it to 

the bill.  

  
To email confirmations, right-click in the owner/dog info area and select ‘Email confirmation’ from the 

pop-up menu. Follow the prompts to send the email. If it went successfully, the notice onscreen will 

change to say it has been sent. This notice will change back to ‘not sent’ if you make changes to the 

entry.  

  

  
  

Right - click in the Bill Items area for a context menu to do  
payments, credits or maintain the existing bill items. The run fees  
item cannot be maintained. It will recalculate every time a class is  
added or deleted. The bill will  combine   all dogs belonging  to the  
same owner.   If you want to combine bills for different owners, e.g.  
husband/wife or parent/child, select the ‘Combine with bill’ option  
on this menu and follow the prompts.   

  
  
  
  
  



Setting your Running Order:  

  
1. The Event Schedule lists all classes with all height divisions that have entries. Click on a class 

name to list the dogs entered. Right-click the name for a pop-up menu with more options.  

2. List of the dogs entered in the selected class.  

3. The current running order. Right-click the heading and select ‘reset’ to auto-renumber the list in 

the order shown.  

4. Click this spot to select a dog, then drag and drop to move forward or back in the list. The 

numbering will auto-update to reflect the new position.  

The Print menu for this form will allow you to print gatesheets and scribesheets. These will print in the 

order shown. If you selected 1 scribesheet per page in the Options, precut your paper to ¼ page to print 

them all in run order.  

Scoring:  

  

  

Select View→Scoring from the main menu.  

  

  

  

  

  

  

  

Select View→ Running Order from the main menu.    

  

  
  



  
Select a class in the Event Schedule list to show the dogs entered. Select a dog from the dog list to enter 

the score for that dog. If the SCT’s have not been entered yet, the SCT shown on the form will be red 

and a dialog will open for you to enter them now. They can also be entered or changed on the ‘Class 

Settings’ form.  

  
1. Dog’s information, read-only.  

2. SCT for the dog’s height division, read-only.  

3. The time format is minutes, seconds, hundredths. If your time is recorded in 

seconds/hundredths only (as shown), just tab or press the period key to move to the seconds 

box then tab or press period to move to the hundredths box.  

4. Use this grid to enter faults for Standard, Jumpers, Steeplechase and Challenge, and points for 

Gamblers and Snooker. The faults/score will be auto-updated as you enter. The tab and enter 

keys will move from box to box in the grid. All numbers appropriate to each class can be entered 

here as well as N (or NC), T and E. The faults/score will be updated as you enter. Quick-entry hint 

– when you are in a grid box, pressing PageDown will save the current score and move to the 

next dog in the list.  

5. Shows the current time faults, read-only.  

6. Shows the current course faults or points as appropriate to the class.  

7. Shows the total faults or score as appropriate to the class.  

8. Pressing ‘E’ in a grid box will check this box, or you can click it to check.  



9. Check this box if the dog is DNR.  

10. Check this box if this is an FEO run. It will be checked for you if the dog was entered as an FEO.  

11. The Q box will auto-check if this was a qualifying run.  

12. Click this button to recalculate this score.  

13. Click this button to reset the time and faults/points to zero for this score.  

14. Click to move to the previous dog in the list.  

15. Click to move to the next dog in the list.  

NOTE on colour coding: The dog names will appear in black if not scored, red if DNR, green if Q’d and 

blue if not.  

Printing results:  

  

Select Print→Results from the main menu when you have the 

Scoring form open. All printing previews first.  

  

  

  
1. Page selection area.  

2. Page size selection.  

3. Print to pdf opens a dialog to select the location. The default is the report folder you selected in 

the ‘Current Trial Settings’ form.  

4. Prints directly to the printer. The printer name is shown on the bottom of the main form at all 

times and can be changed from ‘File→Printer...’ on the main menu.  

5. The number of copies to print.  

NOTE on FEO dogs: They will print on the results at the bottom of their height division without a ranking.  

General notes:  
  

All printing and reports go to preview first and can be saved to pdf or sent to the printer from there.  

If you open both the Entries and Owner settings forms, you can switch between them easily using the 

View Entry and View Owner buttons. The entries list will auto-update if you have added a new dog in 

the Owners form.  

There are many popup menus available when you right click in different areas of the forms.   

To run the program any time after installing, use the desktop shortcut if you installed it or go to your 

Windows start menu→All Programs→AgilityRocks. To check for updates, after starting the program go 

to Help→Check for updates on the main menu.  

I haven’t covered everything, but these are the basics and should get you going. Please email me at 

support@agilityrocks.com if you have any questions or problems.  

  

Jason Ratke 

AgilityRocks! software  

DigitalDogsports 


